TravcoForum.com

Travco Classic Motorhome Support & Discussion Forum

Skip to content

Change font size

Board index » Travco Motor Homes » Travco 270

1972 270 Brake Problems

Unread postby Murtle on Wed Sep 13, 2017 6:35 pm

Hi Friends,
I'm having difficulties with my brakes at this point. I have a 1972 270 travco with the 413 engine. I'm a bit confused on the nomenclature for the vehicles. My manual says it should be a M375 but my van has the dual power brake booster setup that is of the M300 vans. Can anyone clarify?
I bought the beauty (it really is quite lovely :D ) last year and the brakes were spongy back then. I've been tackling many systems but I haven't learned much about the brakes yet. I take it out regularly and they have been operating consistently until this past weekend. I took it out and it had next to no brakes to my chagrin. I pumped the brakes repeatedly and after 3-4 pumps the brakes started to work, but not nearly enough to navigate traffic or intersections.
I located the master brake reservoir above the front drivers wheel. Is this the only place to add fluid? I didn't see a way to gauge how full to have the fluid. I pumped in some new fluid but it appears it had enough fluid in the reservoir. The manual suggests checking the brake booster units (i have two-front/back) next then the wheel brake assemblies. Does anyone have any leads on what this situation sounds like? it looks like the solid metal tubes that connect everything are in good shape. I don't have the setup to be removing wheels and working on the brakes, but may have to acquire such means. Are the brake power booster readily inspect-able? I don't under how the vacuum function works or how to disable it to check for proper functioning...

Any help / wisdom is appreciated. I suspect I'll need to save my money for parts and do as much labor as I can. Can the wheel hoses be replaced without removing the wheels, for example?

Much Appreciation for your Thoughts!
Murtle
New Member
New Member
 
Posts: 8
Joined: Sat Sep 17, 2016 9:42 am
Location: Kentucky
Travco Model: 1972, 270 Rear Dinette

Re: 1972 270 Brake Problems

Unread postby Murtle on Wed Sep 13, 2017 6:37 pm

When I bought the vehicle, it seemed as if the brakes were operating at half capacity.. Is it common for one of the boosters to go out before the other? This may account for the brakes mostly working for the past year (on one booster) and the brakes barely working now with both boosters out..
Murtle
New Member
New Member
 
Posts: 8
Joined: Sat Sep 17, 2016 9:42 am
Location: Kentucky
Travco Model: 1972, 270 Rear Dinette

Re: 1972 270 Brake Problems

Unread postby KB2CRK on Thu Sep 14, 2017 4:28 am

The Hydro vac system was standard on the dodge motor home chassis in 72. I have not worked on a Hydro vac system since the mid eighties. Check the link to daveChieftans website at the top of the page. He has a ton of info on the brakes.
User avatar
KB2CRK
Moderator
Moderator
 
Posts: 873
Joined: Wed Nov 19, 2014 2:26 pm
Location: Arnoldsville GA
Travco Model: 76 Mahal 2+2

Re: 1972 270 Brake Problems

Unread postby Michiganwell on Sun Oct 08, 2017 6:18 pm

Hello, im Pete.
I have a 73 270..same setup.
They also have dual wheel cylinders.dual hoses on rear..rubber lines rot often . Disabling one cylinder..bleed both hydros, there hooked up in series only to make pedal easier.
Get fluid to all slaves ..walla
Michiganwell
New Member
New Member
 
Posts: 13
Joined: Wed Nov 16, 2016 3:10 pm
Travco Model: 1973 270


Return to Travco 270

Who is online

Users browsing this forum: No registered users and 10 guests