TravcoForum.com

Travco Classic Motorhome Support & Discussion Forum

Skip to content

Change font size

Board index » Travco Motor Homes » Travco 270

returned from 1200 mile first trip: sucess!

Unread postby Zed on Thu Aug 31, 2017 1:28 am

After a year of repairs i took my '71 270 on its first trip, ambitiously pulling a International Scout back about 600 miles. Made it safely, although it was hairy at times driving the entire return trip (with trailer) through a rainstorm and a hundred miles of single lane width construction. A brake issue was dealt with on the road. I averaged 5 mpg on my 413 which seems low, it was a expensive trip. RV ran mostly well, slow but steady. Climbing the huge grade outside of Asheville with the trailer was very slow but it steadily made it up the hill. The oil pressure gauge was pinned the entire time and the engine temp ran high, just under the "hot" section the entire trip. It never overheated though. Success but also learning experience, things still aren't really right with this RV. I found out that my left blinker kills the taillight completely when used with the headlights on, not looking forward to tracking that one down. The problem transfers to a trailer when plugged in. Great trip but expensive and at times nerve racking. Still fun though and getting compliments at a music festival while parked next to $400k RVs was nice.
Zed
Contributing Member
Contributing Member
 
Posts: 60
Joined: Fri Aug 12, 2016 12:58 am
Travco Model: 270 Mahal

Re: returned from 1200 mile first trip: sucess!

Unread postby KB2CRK on Fri Sep 01, 2017 10:02 am

Issues with light going out when using other light can usually be attributed to a bad ground. All of the light buckets on the Travco should have ground wires attached as they are mounted in Fiberglas.
User avatar
KB2CRK
Moderator
Moderator
 
Posts: 873
Joined: Wed Nov 19, 2014 2:26 pm
Location: Arnoldsville GA
Travco Model: 76 Mahal 2+2

Re: returned from 1200 mile first trip: sucess!

Unread postby Zed on Fri Sep 01, 2017 8:12 pm

Ok I'll look into that. Lots of PO hacks wiring wise, wire nuts and things like that. I'm going to spend some time with a wiring schematic.
Zed
Contributing Member
Contributing Member
 
Posts: 60
Joined: Fri Aug 12, 2016 12:58 am
Travco Model: 270 Mahal

Re: returned from 1200 mile first trip: sucess!

Unread postby PrivatePilot on Fri Sep 01, 2017 8:34 pm

x2 lights going out almost always being ground related. It's very common on trailers, but I could totally see how it would happen on a Travco as well being a non-grounding body.

I'd bet if you run a good solid ground to the lights you find your problem goes away. :)
- Travcoforum Website Administrator
- Helping a friend - check out Duckies Longarm Quilting in the Oshawa / Durham Region area! www.duckiesquilting.com
User avatar
PrivatePilot
Technician
Technician
 
Posts: 208
Joined: Mon Jan 21, 2013 9:18 pm
Travco Model: N/A (Site Tech!)

Re: returned from 1200 mile first trip: sucess!

Unread postby KB2CRK on Sat Sep 02, 2017 7:41 am

The right headlight and turn signal on Nessie was doing that at one time. It was a broken ground wire to the right side. I ran a new ground wire and it went back to normal.

I wish I had a scout to pull. What part of the country are you in Zed?
User avatar
KB2CRK
Moderator
Moderator
 
Posts: 873
Joined: Wed Nov 19, 2014 2:26 pm
Location: Arnoldsville GA
Travco Model: 76 Mahal 2+2

Re: returned from 1200 mile first trip: sucess!

Unread postby badbillybiker on Sat Sep 02, 2017 8:15 am

Curious...how did the FI work out???
Was looking for the complete install and must have missed it.
BBB
User avatar
badbillybiker
Senior Contributor
Senior Contributor
 
Posts: 649
Joined: Fri Feb 21, 2014 10:32 am
Location: Ohio
Travco Model: 270

Re: returned from 1200 mile first trip: sucess!

Unread postby KB2CRK on Sat Sep 02, 2017 10:07 am

I haven't got it on yet. Still running the Thermoquad.
User avatar
KB2CRK
Moderator
Moderator
 
Posts: 873
Joined: Wed Nov 19, 2014 2:26 pm
Location: Arnoldsville GA
Travco Model: 76 Mahal 2+2

Re: returned from 1200 mile first trip: sucess!

Unread postby Zed on Sun Sep 03, 2017 2:49 pm

I'm in western NC / Asheville area and often Greenville SC area too.

The scout wasn't mine I was towing it as a job for a mechanic I know, get the scout back here and he is supposedly going to do a engine swap on my Toyota pickup. Honestly he started acting like a complete **** after I did my part so we will see, I may be getting ripped off sadly. You wouldn't want this scout to be honest its a complete rust bucket missing significant parts of the floor pans and fenders.

I'll look into the ground wire but I suspect something else as the tail lights light up when the lights are on and the brake lights work, its only when the left blinker and headlights are both on that things go wrong.
Zed
Contributing Member
Contributing Member
 
Posts: 60
Joined: Fri Aug 12, 2016 12:58 am
Travco Model: 270 Mahal

Re: returned from 1200 mile first trip: sucess!

Unread postby Zed on Sun Sep 03, 2017 2:55 pm

Its good to know that the Travco can tow a significant weight though, I may use it to tow my other '71, a Chevy Nova if I decide to move back to Colorado or New Mexico next year. The Travco didn't even seem to slow down noticeably, maintained the 55-60 it was doing without towing, except when I climbed a tall grade, then it slowed down a lot but did the climb without getting any hotter. I had to pay to get a custom hitch welded in by a local good ole boy but it was reasonable and the hitch looks bombproof and preformed (lol) without a hitch.
Zed
Contributing Member
Contributing Member
 
Posts: 60
Joined: Fri Aug 12, 2016 12:58 am
Travco Model: 270 Mahal

Re: returned from 1200 mile first trip: sucess!

Unread postby KB2CRK on Sun Sep 03, 2017 3:34 pm

Scouts in general have gotten too expensive. I am down in Georgia just outside of Athens. The end of this month My wife and I will be going to a vintage trailer show in Maggie Valley NC. We wont be bringing the Travco though. Just a quick trip up for one night.
I have pulled my 86 Dodge D150 behind the Travco and used to have pictures here until Photobucket did the surprise stoppage on hosting.
User avatar
KB2CRK
Moderator
Moderator
 
Posts: 873
Joined: Wed Nov 19, 2014 2:26 pm
Location: Arnoldsville GA
Travco Model: 76 Mahal 2+2

Next

Return to Travco 270

Who is online

Users browsing this forum: Brew and 3 guests